use strict;
my $str = '{{placeholder name="Alexey"}}
sdasdasda
dasdad
ads
asdasd
sdasd
{{/placeholder}}
<div class="asdasdasd">
{{cssArea}}
{{/cssArea}}
{{escaped open="\\"sdfsdf" close=\'dfdfg\'}}
{{/escaped}}
</div>
{{holder name=\'sadasdas\'}}';
my $regex = qr@([^\{\{]++|\{(?!\{))
|
\{\{(\w+)
(?: \s+ (\w+(?:=(?:"((?:\\\\\\\\|\\"|[^"]++)*)"|'((?:\\\\\\\\|\\'|[^']++|)*)'))? ) )*
\}\}
((?R)*)
\{\{/\g{-5}\}\}
|
\{\{(\w+)(?: \s+ (\w+(?:=(?:"((?:\\\\\\\\|\\"|[^"]++)*)"|'((?:\\\\\\\\|\\'|[^']++|)*)'))? )
)*\}\}@mxsp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}