const regex = new RegExp('([^\\{\\{]++|\\{(?!\\{))
|
\\{\\{(\\w+)
(?: \\s+ (\\w+(?:=(?:"((?:\\\\\\\\\\\\\\\\|\\\\"|[^"]++)*)"|\\'((?:\\\\\\\\\\\\\\\\|\\\\\\'|[^\\']++|)*)\\'))? ) )*
\\}\\}
((?R)*)
\\{\\{/\\g{-5}\\}\\}
|
\\{\\{(\\w+)(?: \\s+ (\\w+(?:=(?:"((?:\\\\\\\\\\\\\\\\|\\\\"|[^"]++)*)"|\\'((?:\\\\\\\\\\\\\\\\|\\\\\\'|[^\\']++|)*)\\'))? )
)*\\}\\}', 'gms')
const str = `{{placeholder name="Alexey"}}
sdasdasda
dasdad
ads
asdasd
sdasd
{{/placeholder}}
<div class="asdasdasd">
{{cssArea}}
{{/cssArea}}
{{escaped open="\\"sdfsdf" close='dfdfg'}}
{{/escaped}}
</div>
{{holder name='sadasdas'}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}