#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxs)([^\{\{]++|\{(?!\{)) " & @CRLF & _
"| " & @CRLF & _
"\{\{(\w+)" & @CRLF & _
" (?: \s+ (\w+(?:=(?:"((?:\\\\\\\\|\\"|[^"]++)*)"|'((?:\\\\\\\\|\\'|[^']++|)*)'))? ) )*" & @CRLF & _
"\}\}" & @CRLF & _
" ((?R)*)" & @CRLF & _
"\{\{/\g{-5}\}\} " & @CRLF & _
"| " & @CRLF & _
"\{\{(\w+)(?: \s+ (\w+(?:=(?:"((?:\\\\\\\\|\\"|[^"]++)*)"|'((?:\\\\\\\\|\\'|[^']++|)*)'))? )" & @CRLF & _
")*\}\}"
Local $sString = "{{placeholder name="Alexey"}}" & @CRLF & _
" sdasdasda" & @CRLF & _
"dasdad" & @CRLF & _
"ads" & @CRLF & _
"asdasd" & @CRLF & _
"sdasd" & @CRLF & _
"{{/placeholder}}" & @CRLF & _
"<div class="asdasdasd">" & @CRLF & _
" {{cssArea}}" & @CRLF & _
"" & @CRLF & _
" {{/cssArea}}" & @CRLF & _
"" & @CRLF & _
" {{escaped open="\"sdfsdf" close='dfdfg'}}" & @CRLF & _
" " & @CRLF & _
" {{/escaped}}" & @CRLF & _
"</div>" & @CRLF & _
"{{holder name='sadasdas'}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")