re = /([^\{\{]++|\{(?!\{))
|
\{\{(\w+)
(?: \s+ (\w+(?:=(?:"((?:\\\\\\\\|\\"|[^"]++)*)"|'((?:\\\\\\\\|\\'|[^']++|)*)'))? ) )*
\}\}
((?R)*)
\{\{\/\g{-5}\}\}
|
\{\{(\w+)(?: \s+ (\w+(?:=(?:"((?:\\\\\\\\|\\"|[^"]++)*)"|'((?:\\\\\\\\|\\'|[^']++|)*)'))? )
)*\}\}/mx
str = '{{placeholder name="Alexey"}}
sdasdasda
dasdad
ads
asdasd
sdasd
{{/placeholder}}
<div class="asdasdasd">
{{cssArea}}
{{/cssArea}}
{{escaped open="\\"sdfsdf" close=\'dfdfg\'}}
{{/escaped}}
</div>
{{holder name=\'sadasdas\'}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end