$re = '@([^\{\{]++|\{(?!\{))
|
\{\{(\w+)
(?: \s+ (\w+(?:=(?:"((?:\\\\\\\\\\\\\\\\|\\\\"|[^"]++)*)"|\'((?:\\\\\\\\\\\\\\\\|\\\\\'|[^\']++|)*)\'))? ) )*
\}\}
((?R)*)
\{\{/\g{-5}\}\}
|
\{\{(\w+)(?: \s+ (\w+(?:=(?:"((?:\\\\\\\\\\\\\\\\|\\\\"|[^"]++)*)"|\'((?:\\\\\\\\\\\\\\\\|\\\\\'|[^\']++|)*)\'))? )
)*\}\}@mxs';
$str = '{{placeholder name="Alexey"}}
sdasdasda
dasdad
ads
asdasd
sdasd
{{/placeholder}}
<div class="asdasdasd">
{{cssArea}}
{{/cssArea}}
{{escaped open="\\"sdfsdf" close=\'dfdfg\'}}
{{/escaped}}
</div>
{{holder name=\'sadasdas\'}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);