# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((CLP|[SLP]|AHG)\d+|A\d+\/?\d+|LC\d+|MRKL.*|SC.*)$"
test_str = ("# Social Welfare Life Scinece, PI, PI combined and Legal Expenses 3\n"
"S12\n"
"L123\n"
"P1234\n"
"CLP\n"
"CPL12332123\n"
"CLP1232\n"
"AHG12343\n\n"
"# Online PI\n"
"A12345\n"
"A123/234\n"
"A123/\n\n"
"# Legal expenses 1\n"
"LC1\n"
"lc2\n"
"LC12323213213213123213212312312324343243234243432343234234323432\n\n"
"# Legal Expenses 2\n"
"MRKL\n"
"MRKL32123\n"
"MRKL/0/0/EY/\n\n"
"# Excess Layer\n"
"SCCATDOGMOUSE\n"
"SC123\n"
"SC\n"
"SC$£$£\"\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.