using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((CLP|[SLP]|AHG)\d+|A\d+\/?\d+|LC\d+|MRKL.*|SC.*)$";
string input = @"# Social Welfare Life Scinece, PI, PI combined and Legal Expenses 3
S12
L123
P1234
CLP
CPL12332123
CLP1232
AHG12343
# Online PI
A12345
A123/234
A123/
# Legal expenses 1
LC1
lc2
LC12323213213213123213212312312324343243234243432343234234323432
# Legal Expenses 2
MRKL
MRKL32123
MRKL/0/0/EY/
# Excess Layer
SCCATDOGMOUSE
SC123
SC
SC$£$£""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}