use strict;
my $str = '# Social Welfare Life Scinece, PI, PI combined and Legal Expenses 3
S12
L123
P1234
CLP
CPL12332123
CLP1232
AHG12343
# Online PI
A12345
A123/234
A123/
# Legal expenses 1
LC1
lc2
LC12323213213213123213212312312324343243234243432343234234323432
# Legal Expenses 2
MRKL
MRKL32123
MRKL/0/0/EY/
# Excess Layer
SCCATDOGMOUSE
SC123
SC
SC$£$£"
';
my $regex = qr/^((CLP|[SLP]|AHG)\d+|A\d+\/?\d+|LC\d+|MRKL.*|SC.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}