#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((CLP|[SLP]|AHG)\d+|A\d+\/?\d+|LC\d+|MRKL.*|SC.*)$"
Local $sString = "# Social Welfare Life Scinece, PI, PI combined and Legal Expenses 3" & @CRLF & _
"S12" & @CRLF & _
"L123" & @CRLF & _
"P1234" & @CRLF & _
"CLP" & @CRLF & _
"CPL12332123" & @CRLF & _
"CLP1232" & @CRLF & _
"AHG12343" & @CRLF & _
"" & @CRLF & _
"# Online PI" & @CRLF & _
"A12345" & @CRLF & _
"A123/234" & @CRLF & _
"A123/" & @CRLF & _
"" & @CRLF & _
"# Legal expenses 1" & @CRLF & _
"LC1" & @CRLF & _
"lc2" & @CRLF & _
"LC12323213213213123213212312312324343243234243432343234234323432" & @CRLF & _
"" & @CRLF & _
"# Legal Expenses 2" & @CRLF & _
"MRKL" & @CRLF & _
"MRKL32123" & @CRLF & _
"MRKL/0/0/EY/" & @CRLF & _
"" & @CRLF & _
"# Excess Layer" & @CRLF & _
"SCCATDOGMOUSE" & @CRLF & _
"SC123" & @CRLF & _
"SC" & @CRLF & _
"SC$£$£"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")