package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((CLP|[SLP]|AHG)\d+|A\d+\/?\d+|LC\d+|MRKL.*|SC.*)$`)
var str = `# Social Welfare Life Scinece, PI, PI combined and Legal Expenses 3
S12
L123
P1234
CLP
CPL12332123
CLP1232
AHG12343
# Online PI
A12345
A123/234
A123/
# Legal expenses 1
LC1
lc2
LC12323213213213123213212312312324343243234243432343234234323432
# Legal Expenses 2
MRKL
MRKL32123
MRKL/0/0/EY/
# Excess Layer
SCCATDOGMOUSE
SC123
SC
SC$£$£"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}