re = /\s|\w+|[();,]|[=<>|&%+-]{1,2}/
str = 'name<< 1;
name= 1;
write(var);
write(1+2);
read();'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end