#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s|\w+|[();,]|[=<>|&%+-]{1,2}"
Local $sString = "name<< 1;" & @CRLF & _
"name= 1;" & @CRLF & _
"write(var);" & @CRLF & _
"write(1+2);" & @CRLF & _
"read();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")