import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s|\\w+|[();,]|[=<>|&%+-]{1,2}";
final String string = "name<< 1;\n"
+ "name= 1;\n"
+ "write(var);\n"
+ "write(1+2);\n"
+ "read();";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}