package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s|\w+|[();,]|[=<>|&%+-]{1,2}`)
var str = `name<< 1;
name= 1;
write(var);
write(1+2);
read();`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}