$re = '/\s|\w+|[();,]|[=<>|&%+-]{1,2}/';
$str = 'name<< 1;
name= 1;
write(var);
write(1+2);
read();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);