using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s|\w+|[();,]|[=<>|&%+-]{1,2}";
string input = @"name<< 1;
name= 1;
write(var);
write(1+2);
read();";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}