$re = '/(?!<span class=\'postcolor\'>)[\d\D]+/';
$str = '<span class=\'postcolor\'> Да здраствует хоккей!<br><br><br><br><br><span style=\'font-size:14pt;line-height:100%\'><span style=\'color:red\'>Внимание! Общение свободное, никаких правил, только просьба избегать мат (ну иль хотя бы ставить **), и переходить на личные оскорбления! Welcome!</span></span> <!--Signature--><br><br>--------------------<br><span class=\'signature\'>без любви и ласки не прожить и дня</span><!--E-Signature-->!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);