#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!<span class='postcolor'>)[\d\D]+"
Local $sString = "<span class='postcolor'> Да здраствует хоккей!<br><br><br><br><br><span style='font-size:14pt;line-height:100%'><span style='color:red'>Внимание! Общение свободное, никаких правил, только просьба избегать мат (ну иль хотя бы ставить **), и переходить на личные оскорбления! Welcome!</span></span> <!--Signature--><br><br>--------------------<br><span class='signature'>без любви и ласки не прожить и дня</span><!--E-Signature-->!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")