import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!<span class='postcolor'>)[\\d\\D]+";
final String string = "<span class='postcolor'> Да здраствует хоккей!<br><br><br><br><br><span style='font-size:14pt;line-height:100%'><span style='color:red'>Внимание! Общение свободное, никаких правил, только просьба избегать мат (ну иль хотя бы ставить **), и переходить на личные оскорбления! Welcome!</span></span> <!--Signature--><br><br>--------------------<br><span class='signature'>без любви и ласки не прожить и дня</span><!--E-Signature-->!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}