use strict;
my $str = '<span class=\'postcolor\'> Да здраствует хоккей!<br><br><br><br><br><span style=\'font-size:14pt;line-height:100%\'><span style=\'color:red\'>Внимание! Общение свободное, никаких правил, только просьба избегать мат (ну иль хотя бы ставить **), и переходить на личные оскорбления! Welcome!</span></span> <!--Signature--><br><br>--------------------<br><span class=\'signature\'>без любви и ласки не прожить и дня</span><!--E-Signature-->!';
my $regex = qr/(?!<span class='postcolor'>)[\d\D]+/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}