const regex = /(?!<span class='postcolor'>)[\d\D]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!<span class=\'postcolor\'>)[\\d\\D]+', '')
const str = `<span class='postcolor'> Да здраствует хоккей!<br><br><br><br><br><span style='font-size:14pt;line-height:100%'><span style='color:red'>Внимание! Общение свободное, никаких правил, только просьба избегать мат (ну иль хотя бы ставить **), и переходить на личные оскорбления! Welcome!</span></span> <!--Signature--><br><br>--------------------<br><span class='signature'>без любви и ласки не прожить и дня</span><!--E-Signature-->!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}