using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!<span class='postcolor'>)[\d\D]+";
string input = @"<span class='postcolor'> Да здраствует хоккей!<br><br><br><br><br><span style='font-size:14pt;line-height:100%'><span style='color:red'>Внимание! Общение свободное, никаких правил, только просьба избегать мат (ну иль хотя бы ставить **), и переходить на личные оскорбления! Welcome!</span></span> <!--Signature--><br><br>--------------------<br><span class='signature'>без любви и ласки не прожить и дня</span><!--E-Signature-->!";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}