import Foundation
let pattern = #"((?:[0-9]{1,3},(?:[0-9]{3},)*[0-9]{3}|[0-9]+)(?:.[0-9][0-9])?)\s*(?:ש\"ח|₪|nis|NIS|שקל)(?:\W|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
10,100,000nis
100.00 ש"ח
sfdsf sd34 sdf 3.00 nis
5,000 שקל
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)