re = /((?:[0-9]{1,3},(?:[0-9]{3},)*[0-9]{3}|[0-9]+)(?:.[0-9][0-9])?)\s*(?:ש\"ח|₪|nis|NIS|שקל)(?:\W|$)/
str = '10,100,000nis
100.00 ש"ח
sfdsf sd34 sdf 3.00 nis
5,000 שקל'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end