const regex = new RegExp('((?:[0-9]{1,3},(?:[0-9]{3},)*[0-9]{3}|[0-9]+)(?:.[0-9][0-9])?)\\s*(?:ש\\"ח|₪|nis|NIS|שקל)(?:\\W|$)', 'g')
const str = `10,100,000nis
100.00 ש"ח
sfdsf sd34 sdf 3.00 nis
5,000 שקל`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}