// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"((?:[0-9]{1,3},(?:[0-9]{3},)*[0-9]{3}|[0-9]+)(?:.[0-9][0-9])?)\s*(?:ש\"ח|₪|nis|NIS|שקל)(?:\W|$)"#).unwrap();
let string = "10,100,000nis
100.00 ש\"ח
sfdsf sd34 sdf 3.00 nis
5,000 שקל";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}