using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[0-9]{1,3},(?:[0-9]{3},)*[0-9]{3}|[0-9]+)(?:.[0-9][0-9])?)\s*(?:ש\""ח|₪|nis|NIS|שקל)(?:\W|$)";
string input = @"10,100,000nis
100.00 ש""ח
sfdsf sd34 sdf 3.00 nis
5,000 שקל";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}