$re = '/id="(.*?)"/';
$str = 'id="my_id" class="my_class"';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;