#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "id="(.*?)""
Local $sString = "id="my_id" class="my_class""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)