using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id=""(.*?)""";
string substitution = @"";
string input = @"id=""my_id"" class=""my_class""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}