const regex = /id="(.*?)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('id="(.*?)"', '')
const str = `id="my_id" class="my_class"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);