# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/id="(.*?)"//;t' <<< "id=\"my_id\" class=\"my_class\""