use strict;
my $str = 'id="my_id" class="my_class"';
my $regex = qr/id="(.*?)"/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";