import Foundation
let pattern = #"woicmedjsgoiwsndvwerugwrginvsndfvlkzxdngoisdjgsodivnsldghwseknwoeihwoeig"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
kadlvnlakdvmaldkv
advmkad g
qorgkqorgkq
rgokqdv
lqd,mlqdmc
oqecm
qefmqeoq
efoqr
tiqregqkemq
eogmqeomqefomqe
fq
emoqegm
qegomqeg
qemgoqegmqeogmqev
oqvmado
vjdgo
sdgm
dofkadvo
adkvadog
adgjoer
qgjqeogjqe
gojqecoq
emcoadvm
zdovmzodkogkqrgovegkqeogqe
qoekfqevm,edvos
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"qWERIOTGQOEGI QEV NMQEKVOMQE FBUQIWEF QOIG QEROIG HQEG OIQEG J"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)