# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"woicmedjsgoiwsndvwerugwrginvsndfvlkzxdngoisdjgsodivnsldghwseknwoeihwoeig"
test_str = ("kadlvnlakdvmaldkv\n"
"advmkad g\n"
"qorgkqorgkq\n"
"rgokqdv\n"
"lqd,mlqdmc\n"
"oqecm\n"
"qefmqeoq\n"
"efoqr\n"
"tiqregqkemq\n"
"eogmqeomqefomqe\n"
"fq\n"
"emoqegm\n"
"qegomqeg\n"
"qemgoqegmqeogmqev\n"
"oqvmado\n"
"vjdgo\n"
"sdgm\n"
"dofkadvo\n"
"adkvadog\n"
"adgjoer\n"
"qgjqeogjqe\n"
"gojqecoq\n"
"emcoadvm\n"
"zdovmzodkogkqrgovegkqeogqe\n"
"qoekfqevm,edvos")
subst = "qWERIOTGQOEGI QEV NMQEKVOMQE FBUQIWEF QOIG QEROIG HQEG OIQEG J"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.