const regex = /woicmedjsgoiwsndvwerugwrginvsndfvlkzxdngoisdjgsodivnsldghwseknwoeihwoeig/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('woicmedjsgoiwsndvwerugwrginvsndfvlkzxdngoisdjgsodivnsldghwseknwoeihwoeig', 'gm')
const str = `kadlvnlakdvmaldkv
advmkad g
qorgkqorgkq
rgokqdv
lqd,mlqdmc
oqecm
qefmqeoq
efoqr
tiqregqkemq
eogmqeomqefomqe
fq
emoqegm
qegomqeg
qemgoqegmqeogmqev
oqvmado
vjdgo
sdgm
dofkadvo
adkvadog
adgjoer
qgjqeogjqe
gojqecoq
emcoadvm
zdovmzodkogkqrgovegkqeogqe
qoekfqevm,edvos`;
const subst = `qWERIOTGQOEGI QEV NMQEKVOMQE FBUQIWEF QOIG QEROIG HQEG OIQEG J`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);