// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([\+\-NnSs])?([0-8]?\d|90)[°˚º^~*\s\-_]+([0-5]?\d|\d)([.]\d*)?['′\s\-_]*([\+\-NnSs])?)([,:;\s|\/\\-]+)(([\+\-EeWw])?([0]?\d?\d|1[0-7]\d|180)[°˚º^~*\s\-_]+([0-5]\d|\d)([.]\d*)?['′\s_]*([\+\-EeWw])?)[\s]*$").unwrap();
let string = "//check all zeros
0 0 0 0
0 0.0 0 0.0
0 0.000 0 0.000
0 0.0000 0 0.0000
//check plus and minus signs
+0 0 0 0
+0 0.0 0 0.0
+0 0.000 0 0.000
+0 0.0000 0 0.0000
0 0 +0 0
0 0.0 +0 0.0
0 0.000 +0 0.000
0 0.0000 +0 0.0000
+0 0 +0 0
+0 0.0 +0 0.0
+0 0.000 +0 0.000
+0 0.0000 +0 0.0000
-0 0 0 0
-0 0.0 0 0.0
-0 0.000 0 0.000
-0 0.0000 0 0.0000
0 0 -0 0
0 0.0 -0 0.0
0 0.000 -0 0.000
0 0.0000 -0 0.0000
-0 0 -0 0
-0 0.0 -0 0.0
-0 0.000 -0 0.000
-0 0.0000 -0 0.0000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}