const regex = /^(([\+\-NnSs])?([0-8]?\d|90)[°˚º^~*\s\-_]+([0-5]?\d|\d)([.]\d*)?['′\s\-_]*([\+\-NnSs])?)([,:;\s|\/\\-]+)(([\+\-EeWw])?([0]?\d?\d|1[0-7]\d|180)[°˚º^~*\s\-_]+([0-5]\d|\d)([.]\d*)?['′\s_]*([\+\-EeWw])?)[\s]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([\\+\\-NnSs])?([0-8]?\\d|90)[°˚º^~*\\s\\-_]+([0-5]?\\d|\\d)([.]\\d*)?[\'′\\s\\-_]*([\\+\\-NnSs])?)([,:;\\s|\\\/\\\\-]+)(([\\+\\-EeWw])?([0]?\\d?\\d|1[0-7]\\d|180)[°˚º^~*\\s\\-_]+([0-5]\\d|\\d)([.]\\d*)?[\'′\\s_]*([\\+\\-EeWw])?)[\\s]*$', 'gm')
const str = `//check all zeros
0 0 0 0
0 0.0 0 0.0
0 0.000 0 0.000
0 0.0000 0 0.0000
//check plus and minus signs
+0 0 0 0
+0 0.0 0 0.0
+0 0.000 0 0.000
+0 0.0000 0 0.0000
0 0 +0 0
0 0.0 +0 0.0
0 0.000 +0 0.000
0 0.0000 +0 0.0000
+0 0 +0 0
+0 0.0 +0 0.0
+0 0.000 +0 0.000
+0 0.0000 +0 0.0000
-0 0 0 0
-0 0.0 0 0.0
-0 0.000 0 0.000
-0 0.0000 0 0.0000
0 0 -0 0
0 0.0 -0 0.0
0 0.000 -0 0.000
0 0.0000 -0 0.0000
-0 0 -0 0
-0 0.0 -0 0.0
-0 0.000 -0 0.000
-0 0.0000 -0 0.0000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}