import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([\\+\\-NnSs])?([0-8]?\\d|90)[°˚º^~*\\s\\-_]+([0-5]?\\d|\\d)([.]\\d*)?['′\\s\\-_]*([\\+\\-NnSs])?)([,:;\\s|\\/\\\\-]+)(([\\+\\-EeWw])?([0]?\\d?\\d|1[0-7]\\d|180)[°˚º^~*\\s\\-_]+([0-5]\\d|\\d)([.]\\d*)?['′\\s_]*([\\+\\-EeWw])?)[\\s]*$";
final String string = "//check all zeros\n"
+ "0 0 0 0\n"
+ "0 0.0 0 0.0\n"
+ "0 0.000 0 0.000\n"
+ "0 0.0000 0 0.0000\n\n"
+ "//check plus and minus signs\n"
+ "+0 0 0 0\n"
+ "+0 0.0 0 0.0\n"
+ "+0 0.000 0 0.000\n"
+ "+0 0.0000 0 0.0000\n\n"
+ "0 0 +0 0\n"
+ "0 0.0 +0 0.0\n"
+ "0 0.000 +0 0.000\n"
+ "0 0.0000 +0 0.0000\n\n"
+ "+0 0 +0 0\n"
+ "+0 0.0 +0 0.0\n"
+ "+0 0.000 +0 0.000\n"
+ "+0 0.0000 +0 0.0000\n\n"
+ "-0 0 0 0\n"
+ "-0 0.0 0 0.0\n"
+ "-0 0.000 0 0.000\n"
+ "-0 0.0000 0 0.0000\n\n"
+ "0 0 -0 0\n"
+ "0 0.0 -0 0.0\n"
+ "0 0.000 -0 0.000\n"
+ "0 0.0000 -0 0.0000\n\n"
+ "-0 0 -0 0\n"
+ "-0 0.0 -0 0.0\n"
+ "-0 0.000 -0 0.000\n"
+ "-0 0.0000 -0 0.0000\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}