$re = '/^(([\+\-NnSs])?([0-8]?\d|90)[°˚º^~*\s\-_]+([0-5]?\d|\d)([.]\d*)?[\'′\s\-_]*([\+\-NnSs])?)([,:;\s|\/\\\\-]+)(([\+\-EeWw])?([0]?\d?\d|1[0-7]\d|180)[°˚º^~*\s\-_]+([0-5]\d|\d)([.]\d*)?[\'′\s_]*([\+\-EeWw])?)[\s]*$/m';
$str = '//check all zeros
0 0 0 0
0 0.0 0 0.0
0 0.000 0 0.000
0 0.0000 0 0.0000
//check plus and minus signs
+0 0 0 0
+0 0.0 0 0.0
+0 0.000 0 0.000
+0 0.0000 0 0.0000
0 0 +0 0
0 0.0 +0 0.0
0 0.000 +0 0.000
0 0.0000 +0 0.0000
+0 0 +0 0
+0 0.0 +0 0.0
+0 0.000 +0 0.000
+0 0.0000 +0 0.0000
-0 0 0 0
-0 0.0 0 0.0
-0 0.000 0 0.000
-0 0.0000 0 0.0000
0 0 -0 0
0 0.0 -0 0.0
0 0.000 -0 0.000
0 0.0000 -0 0.0000
-0 0 -0 0
-0 0.0 -0 0.0
-0 0.000 -0 0.000
-0 0.0000 -0 0.0000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);