#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([\+\-NnSs])?([0-8]?\d|90)[°˚º^~*\s\-_]+([0-5]?\d|\d)([.]\d*)?['′\s\-_]*([\+\-NnSs])?)([,:;\s|\/\\-]+)(([\+\-EeWw])?([0]?\d?\d|1[0-7]\d|180)[°˚º^~*\s\-_]+([0-5]\d|\d)([.]\d*)?['′\s_]*([\+\-EeWw])?)[\s]*$"
Local $sString = "//check all zeros" & @CRLF & _
"0 0 0 0" & @CRLF & _
"0 0.0 0 0.0" & @CRLF & _
"0 0.000 0 0.000" & @CRLF & _
"0 0.0000 0 0.0000" & @CRLF & _
"" & @CRLF & _
"//check plus and minus signs" & @CRLF & _
"+0 0 0 0" & @CRLF & _
"+0 0.0 0 0.0" & @CRLF & _
"+0 0.000 0 0.000" & @CRLF & _
"+0 0.0000 0 0.0000" & @CRLF & _
"" & @CRLF & _
"0 0 +0 0" & @CRLF & _
"0 0.0 +0 0.0" & @CRLF & _
"0 0.000 +0 0.000" & @CRLF & _
"0 0.0000 +0 0.0000" & @CRLF & _
"" & @CRLF & _
"+0 0 +0 0" & @CRLF & _
"+0 0.0 +0 0.0" & @CRLF & _
"+0 0.000 +0 0.000" & @CRLF & _
"+0 0.0000 +0 0.0000" & @CRLF & _
"" & @CRLF & _
"-0 0 0 0" & @CRLF & _
"-0 0.0 0 0.0" & @CRLF & _
"-0 0.000 0 0.000" & @CRLF & _
"-0 0.0000 0 0.0000" & @CRLF & _
"" & @CRLF & _
"0 0 -0 0" & @CRLF & _
"0 0.0 -0 0.0" & @CRLF & _
"0 0.000 -0 0.000" & @CRLF & _
"0 0.0000 -0 0.0000" & @CRLF & _
"" & @CRLF & _
"-0 0 -0 0" & @CRLF & _
"-0 0.0 -0 0.0" & @CRLF & _
"-0 0.000 -0 0.000" & @CRLF & _
"-0 0.0000 -0 0.0000" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")