using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([\+\-NnSs])?([0-8]?\d|90)[°˚º^~*\s\-_]+([0-5]?\d|\d)([.]\d*)?['′\s\-_]*([\+\-NnSs])?)([,:;\s|\/\\-]+)(([\+\-EeWw])?([0]?\d?\d|1[0-7]\d|180)[°˚º^~*\s\-_]+([0-5]\d|\d)([.]\d*)?['′\s_]*([\+\-EeWw])?)[\s]*$";
string input = @"//check all zeros
0 0 0 0
0 0.0 0 0.0
0 0.000 0 0.000
0 0.0000 0 0.0000
//check plus and minus signs
+0 0 0 0
+0 0.0 0 0.0
+0 0.000 0 0.000
+0 0.0000 0 0.0000
0 0 +0 0
0 0.0 +0 0.0
0 0.000 +0 0.000
0 0.0000 +0 0.0000
+0 0 +0 0
+0 0.0 +0 0.0
+0 0.000 +0 0.000
+0 0.0000 +0 0.0000
-0 0 0 0
-0 0.0 0 0.0
-0 0.000 0 0.000
-0 0.0000 0 0.0000
0 0 -0 0
0 0.0 -0 0.0
0 0.000 -0 0.000
0 0.0000 -0 0.0000
-0 0 -0 0
-0 0.0 -0 0.0
-0 0.000 -0 0.000
-0 0.0000 -0 0.0000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}