import Foundation
let pattern = #"(?:^|\W)([0-9]+_[a-zA-Z0-9])\w+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
A1_aaa123
9_1aa123
A_aaa12
1_aa123
1_jjj112
2_aslk
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}