#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^|\W)([0-9]+_[a-zA-Z0-9])\w+"
Local $sString = "A1_aaa123" & @CRLF & _
"9_1aa123" & @CRLF & _
"A_aaa12" & @CRLF & _
"1_aa123" & @CRLF & _
"1_jjj112" & @CRLF & _
"2_aslk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")