const regex = /(?:^|\W)([0-9]+_[a-zA-Z0-9])\w+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\W)([0-9]+_[a-zA-Z0-9])\\w+', '')
const str = `A1_aaa123
9_1aa123
A_aaa12
1_aa123
1_jjj112
2_aslk
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}