import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\W)([0-9]+_[a-zA-Z0-9])\\w+";
final String string = "A1_aaa123\n"
+ "9_1aa123\n"
+ "A_aaa12\n"
+ "1_aa123\n"
+ "1_jjj112\n"
+ "2_aslk\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}