// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^|\W)([0-9]+_[a-zA-Z0-9])\w+").unwrap();
let string = "A1_aaa123
9_1aa123
A_aaa12
1_aa123
1_jjj112
2_aslk
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}