package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|\W)([0-9]+_[a-zA-Z0-9])\w+`)
var str = `A1_aaa123
9_1aa123
A_aaa12
1_aa123
1_jjj112
2_aslk
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}