import Foundation
let pattern = #"^((0[1-9]|[12]\d|3[01])\/(0[3578]|1[02])\/((202[1-9])))$|^((0[1-9]|[12]\d|30)\/(0[469]|11)\/((202[1-9])))$|^((0[1-9]|[1]\d|(2[0-8]))\/(02)\/(202[2-9]))$|^((0[1-9]|[12]\d|3[01])\/(01)\/((202[2-9])))$|^((2[0-8])\/(02)\/(2021))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
11/02/2022
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)