const regex = /^((0[1-9]|[12]\d|3[01])\/(0[3578]|1[02])\/((202[1-9])))$|^((0[1-9]|[12]\d|30)\/(0[469]|11)\/((202[1-9])))$|^((0[1-9]|[1]\d|(2[0-8]))\/(02)\/(202[2-9]))$|^((0[1-9]|[12]\d|3[01])\/(01)\/((202[2-9])))$|^((2[0-8])\/(02)\/(2021))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((0[1-9]|[12]\\d|3[01])\\\/(0[3578]|1[02])\\\/((202[1-9])))$|^((0[1-9]|[12]\\d|30)\\\/(0[469]|11)\\\/((202[1-9])))$|^((0[1-9]|[1]\\d|(2[0-8]))\\\/(02)\\\/(202[2-9]))$|^((0[1-9]|[12]\\d|3[01])\\\/(01)\\\/((202[2-9])))$|^((2[0-8])\\\/(02)\\\/(2021))$', 'gm')
const str = `11/02/2022
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}